1 2 3

主图高抛低吸

[复制链接]
查看1071 | 回复0 | 2023-4-16 17:02:50 | 显示全部楼层 |阅读模式
指标公式编辑
QQ截图20230416170156.jpg
  1. EMA13:=EMA(C,13),COLORWHITE;
  2. EMA21:=EMA(C,21),COLORYELLOW;
  3. EMA34:=EMA(C,34),COLORFF00FF;
  4. EMA60:=MA(C,60),COLORFFCC66;
  5. VAR2:=(2*CLOSE+HIGH+LOW)/4;
  6. VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
  7. VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
  8. 散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
  9. 庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
  10. DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
  11. DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;
  12. DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
  13. DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
  14. VAR9:=CLOSE-REF(CLOSE,5);
  15. VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
  16. VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
  17. 卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
  18. DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
  19. 卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
  20. B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
  21. S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
  22. VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
  23. S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
  24. A0:=(L+H+C*2)/4;
  25. A1:EMA(A0,14)COLORBLUE,LINETHICK2;
  26. A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
  27. A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
  28. A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
  29. 看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
  30. 逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
  31. 买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;
  32. 卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3;
  33. STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
  34. STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
  35. STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
  36. STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
复制代码


您需要登录后才可以回帖 登录 | 立即注册

本版积分规则