1 2 3

MACD背离抄底信号

    [复制链接]
查看206251 | 回复130 | 2018-8-7 18:48:21 | 显示全部楼层 |阅读模式
指标公式编辑
  1. DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
  2. DEA:EMA(DIFF,9);
  3. MACD:=2*(DIFF-DEA);
  4. STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
  5. STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;
  6. STICKLINE(MACD,0,MACD,4,0 ),COLOR00AAFF;
  7. STICKLINE(MACD,0,MACD,3.3,0 ),COLOR00BBFF;
  8. STICKLINE(MACD,0,MACD,2.2,0 ),COLOR00CCFF;
  9. STICKLINE(MACD,0,MACD,1.65,0 ),COLOR00DDFF;
  10. STICKLINE(MACD,0,MACD,1.1,0 ),COLOR00EEFF;
  11. STICKLINE(MACD,0,MACD,0.55,0 ),COLOR00FFFF;
  12. STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR0000AA;
  13. STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.3 ,0 ),COLOR0011BB;
  14. STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR0022CC;
  15. STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.65 ,0 ),COLOR0033DD;
  16. STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1 ,0 ),COLOR0044EE;
  17. STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.55 ,0 ),COLOR0055FF;
  18. STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORAA00BB;
  19. STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORBB11BB;
  20. STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORCC22BB;
  21. STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.65,0 ),COLORDD33BB;
  22. STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLOREE44BB;
  23. STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFF55BB;
  24. STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORFFAA00;
  25. STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORFFBB11;
  26. STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORFFCC22;
  27. STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.65 ,0 ),COLORFFDD33;
  28. STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.1 ,0 ),COLORFFEE44;
  29. STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFFFF55;
  30. IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;
  31. IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;
  32. IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
  33. 低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
  34. STICKLINE(低位金叉,0,-0.18,6,0),COLORYELLOW;
  35. DRAWTEXT(低位金叉,-0.1,' 低位金叉'),COLORYELLOW;
  36. JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
  37. 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
  38. STICKLINE(二次金叉,0,-0.18,6,0),COLORFF00FF;
  39. DRAWICON(二次金叉,DEA*1.04,13) ;
  40. DRAWTEXT(二次金叉,-0.1,' 二次金叉'),COLORFF00FF;
  41. A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
  42. 底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
  43. STICKLINE(底背离,0,0.13,6,0),COLOR00FF00;
  44. DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
  45. DRAWTEXT(底背离,0.1,' 底背离'),COLOR00FF00;
  46. A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
  47. 顶背离:=REF(CLOSE,A2+1)<DIFF AND CROSS(DEA,DIFF);
  48. DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;
复制代码


QQ截图20190911181133.png





WXch0Fx | 2020-9-20 17:54:13 | 显示全部楼层
MACD背离抄底信号
王长虹 | 2020-9-18 08:50:51 | 显示全部楼层
谢谢
dlj1129 | 2020-8-25 11:12:55 | 显示全部楼层
学学习
henry | 2020-4-9 22:57:29 | 显示全部楼层
这背离信号很好,马上轻仓介入,时刻关注
maodan | 2020-4-8 22:28:24 | 显示全部楼层
老师威武!
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则