找回密码
 立即注册

扫一扫 微信快速登陆

QQ登录

只需要一步,快速开始

手机号码,快捷登录

淘股利器体验版
开启左侧

通达信自动画波段黄金分割主力指标

  [复制链接]
发表于 2018-7-29 11:35:06 | 显示全部楼层 |阅读模式
易投金股池
N:=10;P:=60;
趋势:ZIG(3,N);
↑:TROUGHBARS(3,N,1),COLOR0000FF,NODRAW;
↓:PEAKBARS(3,N,1),COLOR00FF00,NODRAW;
低:IF(↑=0,C,IF(↓<↑,TROUGH(3,N,1),REF(TROUGH(3,N,1),1))),COLOR00FFFF,NODRAW;
涨%:IF(↑<↓,(C/低-1)*100,REF((C/低-1)*100,↓)),COLOR0000FF,NODRAW;
高:IF(↓=0,C,IF(↑<↓,PEAK(3,N,1),REF(PEAK(3,N,1),1))),COLOR00FF00,NODRAW;
跌%:IF(↓<↑,(C/高-1)*100,REF((C/高-1)*100,↑)),COLORFFFF00,NODRAW;
{以下设置主图显示方式}
上:IF(趋势>REF(趋势,1),趋势,DRAWNULL),COLORRED,LINETHICK2;
下:IF(趋势<REF(趋势,1),趋势,DRAWNULL),COLORGREEN,LINETHICK2;
STICKLINE(↑=0,H*1.01,高,0,0),COLOR00FF00;
STICKLINE(↓=0,L*0.99,低,0,0),COLORFF00FF;
STICKLINE(BETWEEN(↑,0,7),低,低,3,1),COLOR00FFFF;
STICKLINE(BETWEEN(↓,0,7),高,高,3,1),COLOR00FF00;
STICKLINE(↑<↓,低,低,1,1),COLOR00FFFF;
STICKLINE(↓<↑,高,高,1,1),COLOR00FF00;
{以下设置黄金分割}
[share] KJ:=高-低;
H1:高-KJ*0.191,COLOR00FFFF,NODRAW;
H2:高-KJ*0.382,COLOR0000FF,NODRAW;
H3:高-KJ*0.500,COLORFFFFFF,NODRAW;
H4:高-KJ*0.618,COLORFF00FF,NODRAW;
H5:高-KJ*0.809,COLOR00FF00,NODRAW;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<高,高,高,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H1,H1,H1,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H2,H2,H2,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H3,H3,H3,1,1),COLORFFFFFF;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H4,H4,H4,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H5,H5,H5,1,1),COLOR00FF00;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H1,H1,H1,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H2,H2,H2,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H3,H3,H3,1,1),COLORFFFFFF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H4,H4,H4,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H5,H5,H5,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>低,低,低,1,1),COLORFF00FF;
ZHSJ:=IF(↓<↑,BACKSET(ISLASTBAR,↓),IF(↑<↓,BACKSET(ISLASTBAR,↑),0));
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H1,'险'),COLOR00FFFF;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H2,'高'),COLOR00FFFF;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H3,'中'),COLOR00FF00;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H4,'低'),COLOR00FFFF;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H5,'支'),COLOR00FFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H1,'压'),COLORFFFFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H2,'高'),COLORFFFFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H3,'中'),COLOR0000FF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H4,'低'),COLORFFFFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H5,'弹'),COLORFFFFFF;[/share]
波段黄金分割.png

--------------------------------


发表于 2020-9-15 23:33:16 | 显示全部楼层
谢谢分享!
发表于 2019-11-19 10:01:54 | 显示全部楼层
通达信自动画波段黄金分割主力指标
http://jncg123.com/forum.php?mod ... 23&fromuid=3683
(出处: 易投软件)


发表于 2019-11-19 09:59:55 | 显示全部楼层
经济
发表于 2019-11-19 09:59:52 | 显示全部楼层
经济
  • 通达信缠论自动画笔段中枢及大小级别123类
  • 缠论技术:画笔、段、顶分型、底分型(文华
  • 筹码突破选股买在牛股爆发点+筹码实战运用
  • 淘股利器-体验用户:自助充值/月卡
  • 火箭发射选股预警指标
  • 股票公式指标编辑教程视频学习在线辅助答疑
最新热门快捷标签
易投公众号
X
返回顶部快速回复上一主题下一主题返回列表
 
QQ在线咨询
咨 询 热 线
15819922659
工 作 时 间
8:00-22:00

Copyright © 易投社区| 联系管理员|Archiver|手机版|小黑屋|易投社区 ( 粤ICP备17135355号 )

GMT+8, 2020-9-25 14:02 , Processed in 0.114651 second(s), 64 queries .

返回顶部 返回列表